Lag, Freeze, Pauses... Fixed

Got a Glitch? Always Lagging? Need help with anything technical? Want to move off Windows XP?
Post Reply
User avatar
TotalBurn
Posts: 153
Joined: Wed Jun 09, 2021 10:46 am

Lag, Freeze, Pauses... Fixed

Post by TotalBurn »

Hey everyone, been a while since I was playing online or posting. Some of you might remember last year I was talking about where the game would have random pauses, where my screen would freeze for a split second. During the pause the game and audio would continue and once unfrozen, players etc would be slightly moved. Alright you get it.


After months of playing offline I found different ways to lessen or mitigate the problem. But it wasnt until I switched of "Dynamic Lighting" that the problem was fixed for good.

Some scenarios where the pause would take place were Link gun alt fire, Link tanks and any form of redeemer. I havent tried online game play yet but as far as offline the Dynamic lighting solves the problem completely.

BTW Happy New Year to the Omni community!
User avatar
pooty
Posts: 4815
Joined: Sat Apr 03, 2021 10:22 am
Location: Michigan
Server Sponsor: Yes
Server Admin: Yes

Re: Lag, Freeze, Pauses... Fixed

Post by pooty »

Happy New Year to you as well.
I wonder if that's related to a video card setting? I've had that issue occasionally, and usually a reboot of the computer solves it.
User avatar
TotalBurn
Posts: 153
Joined: Wed Jun 09, 2021 10:46 am

Re: Lag, Freeze, Pauses... Fixed

Post by TotalBurn »

I thought it was a setting too. I have an NVidia RTX 3060 ti. When I would use the quick settings (balanced & performance) it reduced the problem but didnt get rid of it completely. I chalked it up to the game is so old that the drivers arent providing the legacy support.

I had turned off dynamic lighting to test a map and noticed the frame rate was smoother. For a week I played all the offending maps and no issues. Funny thing is that visually I dont think I notice the lack of dynamic lighting.
User avatar
captainsnarf
Posts: 2875
Joined: Tue Jul 06, 2021 1:51 pm
Location: Washington
Server Sponsor: Yes
Server Admin: Yes
Contact:

Re: Lag, Freeze, Pauses... Fixed

Post by captainsnarf »

There's not a lot of dynamic lighting in UT2004. Most noticeable are the headlights of the vehicles which are dynamic lights.
User avatar
TotalBurn
Posts: 153
Joined: Wed Jun 09, 2021 10:46 am

Re: Lag, Freeze, Pauses... Fixed

Post by TotalBurn »

Thats what I thought also. From what I read anything that is moving, emitting light can cast dynamic light on another object. Someone wrote in an example that the alt fire of the link gun and shock rifle will cast light on objects that are near by, including players. When you are in the heat of the action who notices these things?

I think it could be a nuance visual that I can easily live without.

I made a side by side screenshot here
User avatar
EmanReleipS
Posts: 42
Joined: Wed Jun 09, 2021 1:11 am

Re: Lag, Freeze, Pauses... Fixed

Post by EmanReleipS »

A couple of other things peeps can try if you are experiencing lag, freezes, etc...

1) Check the size of your UT2004's user.ini in your System folder. Sometimes this gets bloated due to error messages. Delete any duplicate entries.

2) If you are using Mozilla Firefox while gaming, check your RAM. Sometimes Firefox will eat up all of it, in particular if you have several tabs open or if you have a bunch of extensions installed. Unfortunately this is a reoccuring problem with this browser.

3) User WinMTR to check if there are any bad hops between you and the server. Just enter the server IP without the port number and watch the "loss" column.

Checking these points might help answer the "is it me or is it the server?" question.
Post Reply